Textura se ve en color negro en Cycles

Preguntas y respuestas relacionadas con el proceso de render usando Blender Internal, Yafaray, Cycles, LuxRender, Vray, MentalRay, Renderman, Aqsis, Pixie, Octane, etc.
Responder
bennu
Mensajes: 5
Registrado: Lun Sep 06, 2010 6:51 pm
Nombre:

Textura se ve en color negro en Cycles

Mensaje por bennu » Mar Jun 05, 2012 2:07 pm

Un saludo a todos, este mi primer post en la comunidad, y es que no encuentro por ningún lado solución a mí problema, estoy trabajando en Blender 2.63 y en Cycles, la cuestión es que al cargar una textura en cualquier objeto de mi modelo esta se ve en negro, lo curioso es que en la vista previa de textura se ve que esta aplicada al objeto pero en la vista de renderizado sale totalmente en negro obviamente el render sale igual, adjunto la imagen por si alguién tiene una idea de lo que pueda estar haciendo mal al aplicar la textura UV, Gracias!
Imagen

D4rB
Mensajes: 1045
Registrado: Mar Nov 16, 2010 12:46 pm
Nombre: .
Ubicación: México
Contactar:

Re: Textura se ve en color negro en Cycles

Mensaje por D4rB » Jue Jun 07, 2012 11:05 am

Hola,
¿Tu textura está empaquetada dentro del archivo .blend?
sí es así desempaquétala y luego vuelve a intentar
Chat IRC de la comunidad g-blender
http://webchat.freenode.net/?channels=g-blender
canal #g-blender
Otra forma de estar en contacto con la comunidad

bennu
Mensajes: 5
Registrado: Lun Sep 06, 2010 6:51 pm
Nombre:

Re: Textura se ve en color negro en Cycles

Mensaje por bennu » Jue Jun 07, 2012 8:12 pm

Gracias por contestar, efectivamente estaba empaquetada en el mismo archivo, la desempaquete y volví a empaquetar sigue igual, he realizado también la carga de la imagen desde una carpeta externa y nada no logro ver la textura, será algo en las preferencias de usuario tal vez?

D4rB
Mensajes: 1045
Registrado: Mar Nov 16, 2010 12:46 pm
Nombre: .
Ubicación: México
Contactar:

Re: Textura se ve en color negro en Cycles

Mensaje por D4rB » Vie Jun 08, 2012 8:44 am

A mi me paso ya antes y con desempaquetarla funcionó, inténtalo en un proyecto nuevo, quizás le moviste o presionaste a algo que las deshabilitó, inténtalo también en ese archivo en un objeto distinto con otra textura y si funciona luego inténtalo con la del problema, pero no la reempaquetes.
Chat IRC de la comunidad g-blender
http://webchat.freenode.net/?channels=g-blender
canal #g-blender
Otra forma de estar en contacto con la comunidad

bennu
Mensajes: 5
Registrado: Lun Sep 06, 2010 6:51 pm
Nombre:

Re: Textura se ve en color negro en Cycles

Mensaje por bennu » Mar Jun 12, 2012 7:43 pm

No la verdad no encuentro el problema, quito la textura la vuelvo a cargar, le pongo textura también a la piel del modelo y nada, sigue igual, lo raro es que en la versión 2.62 la textura carga perfecto, lo malo es que pierdo el trabajo de escultura que tiene la malla del archivo de la versión 2.63, en fin voy aseguir checando, Gracias!

Ende
Mensajes: 2
Registrado: Mar May 22, 2012 2:43 pm
Nombre:

Re: Textura se ve en color negro en Cycles

Mensaje por Ende » Mié Jun 13, 2012 1:31 am

Al parecer esto es un error en Cycles y esta documentado.
La informacion esta en ingles, pero quiza google te pueda ayudar...

Aqui alguien lo reporto y adjunto un archivo recreando el mismo error.

http://projects.blender.org/tracker/?fu ... group_id=9

Y esta es la lista de errores documentados:
-\"Packed, painted or animated image textures do not work.\"

http://wiki.blender.org/index.php/Dev:2 ... nownIssues

Quiza creaste el archivo en una version anterior o incluso en otro computador y eso esta causando el error... Quiza te sirva crear un archivo nuevo en la ultima version y usar la funcion de APPEND FROM LIBRARY (SHIFT + F1). Solo importa el objeto o mesh... y luego crea los materiales nuevamente con la textura local.

Suerte!

Ende,

Avatar de Usuario
Warcos
Mensajes: 381
Registrado: Lun May 09, 2011 12:00 pm
Nombre: Marcos Antonio Ruiz Guindo
Ubicación: Ciudad Guantanamo
Contactar:

Re: Textura se ve en color negro en Cycles

Mensaje por Warcos » Mié Jun 13, 2012 1:21 pm

tambiem me paso al principio con Cycles....
(el error me daba cuando trabajaba en una compu... y luego iva a otra a renderizar o a continuar el trabajo)
y lo solucione de esta forma

cuando trabajo al terminar voy a:
Archivo ---> Informacion externa ---> Empaquetar en archivos.blend

(el unico inconveniente es que si estas usando imagenes muyyyy grandes aunque sea un cubito el fichero mesa muuucho)

al cambiar a otra computadora antes que todo voy a:
Archivo ---> Informacion externa ---> Desempaquetar en archivos ----> (guardar los archivos en el directorio actual. sobreescribiendo los existentes)

entonces Blender crea una carpeta llamada textures en el directorio de el archivo .blend.... donde guarda las texturas del fichero

f12 y cycles renderiza bien..

(si vas a guardar e irte para otro lugar hay que hacer el mismo trabajo...)

parece extraño pero puedes probar ....

bennu
Mensajes: 5
Registrado: Lun Sep 06, 2010 6:51 pm
Nombre:

Re: Textura se ve en color negro en Cycles

Mensaje por bennu » Mié Jun 13, 2012 9:16 pm

Estuve checando la info del bug que me envia Ende, despues cambie la ruta de las imagenes de la carpeta donde se encuentran al escritorio de la PC y es la unica forma en como las carga, adjunto la imagen de la carpeta que muestra las imagenes desde el escritorio de la pc, se puede ver que el blender muestra las imagenes de las carpeta sin problemas Imagen
y aca esta la otra ruta que va a la carpeta donde tengo el archivo de blender Unicamente se ven como si fueran archivos de texto y no imagenes :-o por eso no las carga ni las procesa Cycles Imagen

En fin :roll:, esta es la textura aplicada desde el escritorio de mi PC Imagen lo ideal es que se pueda aplicar la textura desde la ruta de la carpeta original del archivo del blend.

Gracias por responder Warcos y Ende, sigo moviendole para encontrar el problema Salu2

matinadi
Mensajes: 10
Registrado: Mié Ene 03, 2007 3:09 pm
Nombre:

Re: Textura se ve en color negro en Cycles

Mensaje por matinadi » Lun Jun 18, 2012 2:29 am

Hola.

Buscando por el mismo problema he dado con este mensaje.... y haciendo todas las pruebas recomendadas, seguía sin funcionar.

Pero finalmente, me dio por hacer una última y simplemente fue cambiar el nombre de la carpeta que contenía las imágenes de las texturas.

No se porqué pero Blender no entendía que el nombre de mi carpeta tuviera una palabra acentuada \"Práctica\".

A mi por lo menos me ha funcionado.... prueba.

Por cierto, yo personalmente en lugar de utilizar el sistema de empaquetar en un archivo .blend (para evitar el excesivo tamaño del archivo si utilizas fotos grandes), suelo utilizar otro método.

Una vez que tienes el proyecto creado y cada vez que añadas alguna imagen para formar una textura, haces lo siguiente: File >>> External Data >>> Make All Paths Relatives. De esta forma en una sola carpeta puedes llevar todos los archivos del proyecto y trabajar en distintos ordenadores sin problema.

Salu2.

bennu
Mensajes: 5
Registrado: Lun Sep 06, 2010 6:51 pm
Nombre:

Re: Textura se ve en color negro en Cycles

Mensaje por bennu » Dom Ago 19, 2012 5:48 pm

matinadi
simplemente fue cambiar el nombre de la carpeta que contenía las imágenes de las texturas. No se porqué pero Blender no entendía que el nombre de mi carpeta tuviera una palabra acentuada "Práctica".
Efectivamente matinadi, resulta que la carpeta de todos los proyectos de Blender tenía una(ñ)entonces no cargaba la textura el Cycles, lo raro es que hasta esta versión con el motor cycles pasa esto en fin, problema finalmente resuelto, Muchas Gracias, un Saludo también!

Tarzan
Mensajes: 1
Registrado: Sab Nov 17, 2018 6:37 pm
Nombre: Cristins

Re: Textura se ve en color negro en Cycles

Mensaje por Tarzan » Sab Nov 17, 2018 6:44 pm

Yo he encontrado una solución tonta: he agrupado los objetos que sí se veían con el que salía en negro. Y lo ha renderizado bien. Pero he perdido calidad en la textura del resto de objetos. Así que sigo teniendo un problema.

Responder